The Menu

Digital Pipe Fitter uses the following menu.


New Joint

"New Joint" is used to open a new joint window. A list of available joints will appear with utility joints grouped at the bottom of the list. Joints that involve rolling your own components are included in a separate submenu called "Rolled Joints". Select the menu item "Select a Joint..." to use the joint selection wizard. The joint selection wizard includes pictures and short descriptions of the joints to aid in selection.

Open Joint/Project

"Open Joint/Project" opens the file open dialog box to select a saved joint to view. Both joints and projects are saved as .pcj files. If a file containing a project is opened, all joints in that project are opened and all currently opened joints will be closed to make room for that project. Only one project can be opened at a time since by definition a project is all currently opened joints. If a file contains a single joint, opening it will add it to the existing project.

Open Recent

"Open Recent" presents a list of the most recently viewed files. Select from the list the file to be opened. If there is a (p) before the filename in the list, that file contains a project.

Save Joint

"Save Joint" will save the currently selected joint to disk. If it is a new joint that has not previously been saved, the user will be asked for a filename. All joints and projects should be saved with a .pcj file extension.

Save Joint As

"Save Joint As" will save the currently selected joint to a new file.

Save Project

"Save Project" saves all open joints to a single .pcj file. If the current project was opened as a project or was previously saved with "Save Project As", then the project will be saved using the existing file name. See the Projects page in the manual for more details.

Save Project As

"Save Project As" saves all open joints to a single .pcj file. This collection of joints can later be loaded with the "File - Open Joint/Project" menu item.

Close Joint

"Close Joint" will close the currently open joint and ask the user if it is to be saved if it has been edited. To close all windows, use either the "Window - Close All" or "File - Close Project" menu item.

Close Project

"Close Project" will close all the currently opened joints and ask the user if it is to be saved if it has been edited.

Duplicate Joint

"Duplicate Joint" will create a copy of the currently selected joint. The joint name of the new joint will be numerically incremented from the name of the original joint.

Store as Default

"Store as Default" is the way to store the default state used by a new joint when opened up in the future. First set the parameters of a joint to the desired values. Then select the "File - Store as Default" menu item. After this, the next time a joint of this type is created it will contain these default parameters. If a user commonly uses one size of pipe for much of their work, this feature will save time. Also, the units setting associated with the joint (inches or mm) is saved with this command.

Printer Setup

"Printer Setup" selects the printer to be used for printing templates. Other properties unique to the printer can be changed here as well. Selecting between landscape and portrait orientation can in same cases minimize the number of pages needed to print a template.

Page Setup

"Page Setup" sets margins and orientation for printing. Smaller margins mean less pages to print a template.


"Exit" will close the Digital Pipe Fitter application. If any open joints or the entire current project have been edited and not saved, the user will be asked if they want to save the joints or not.


Under the "Print" main menu item is a list of template pages that are ready to be printed from the currently selected joint. A purchased license is required to print templates. There is one exception. In order to allow testing of printer compatibility, printing is always allowed for Branch Joints with a Branch Angle of 53 degrees. If you open a Branch Joint and set the Branch Angle to 53 degrees, then printing will be enabled for that joint, even if you do not own a license.

Digital Pipe Fitter can print a report file that includes the template scaled to fit on one page along with the current settings and a list of ordinate measurements to be used to measure the cuts manually without the need of a full sized template. See the "Report" submenu for this feature.

Digital Pipe Fitter can 'print' to an AutoCad® DXF file. On the print menu is a submenu called "Export DXF". Select a component under this submenu to write that component's cutline to disk. The DXF file contains the same axis and labels that the print version contains. Use this feature to incorporate drawings of the cutlines into your official documentation.

Digital Pipe Fitter can save a screen capture of the current preview window. On the print menu is a submenu called "Save Preview Image". Specify a filename and the template or 3D image currently being viewed will be saved. The image can be saved in .jpg .png or .bmp formats. If the Ctrl button on the keyboard is being pressed when the "Save Preview Image" menu item is selected, and the 3D preview window is currently being viewed, then a 3D polygon model can be saved .wrl format.



Opens the settings window. The settings window is used to set line colors, template thickness, enable ordinate lines and control other printing options.

inches mm

Each joint can independently be set to use either inches or millimeters as its units of measure. These menu items and the associated buttons on the button bar will switch the units of measure on the currently selected joint. Utility Joints can reference other joints using different units of measure and create an accurate result in whichever units desired.


Opens the license window. This window is used to register your purchased license to enable printing. It also shows the current state of your existing license.


The "Window" menu contains standard window manipulation functions. The currently open joint windows can be tiled or placed in a cascade arrangement. Windows minimized to the bottom of the application window can be arranged. Also, all open joint windows can be closed with the "Close All" menu item.



Requires a default browser. Opens a local version of this manual.

Check for Update

"Check for Updates" opens your default web browser and checks with if your current version is the most recent. No information other than the current running version number is sent to the server.

Online Support

"Online Support" opens your default web browser to

Be sure to check occasionally for new versions of the software.


"About" shows version number, license agreement and contact information.